Cannot create admin user after upgrade and rebuild

hello,
I was upgrading to newest Portainer after having my system running for a month. I pulled the new image and after rebuild I got some errors so I removed the container and the volume, cleaned browser caches and rebuild container again. I can access the webpage but cannot create a new admin user (error unable to create admin user). Here are my logs.

server: Listening on 0.0.0.0:8000…
Starting Portainer 2.1.1 on :9000
[DEBUG] [chisel, monitoring] [check_interval_seconds: 10.000000] [message: starting tunnel management process]
http error: No administrator account found inside the database (err=Object not found inside the database) (code=404)

Can it be that this has to do something with permissions on path var/lib/docker/volumes? I changed the permissions to be able to Samba share them… Owner is root:root
drwx-----x 3 root root 4096 Mar 25 22:49 portainer_portainer_data
drwxr-xr-x 5 root root 4096 Mar 25 22:49 _data
Seems fine for me…or?

Thanks for helping,
Chris

Docker-compose.yml

version: ‘2’

services:
portainer:
image: portainer/portainer-ce:latest
container_name: portainer
command: -H unix:///var/run/docker.sock
restart: unless-stopped
volumes:
- /var/run/docker.sock:/var/run/docker.sock
- portainer_data:/data
labels:
- traefik.enable=true
- traefik.http.routers.portainer.rule=Host(mydomain)
- traefik.http.routers.portainer.entrypoints=web-secure
- traefik.http.routers.portainer.tls=true
- traefik.http.routers.portainer.tls.certresolver=primary
- traefik.http.services.portainer.loadbalancer.server.port=9000
- traefik.http.routers.portainer.middlewares=auth
networks:
- web
networks:
web:
external: true
volumes:
portainer_data:

Come on! Is there really noone able to help? Please…

Hi
apologies this wasn’t noticed, However same query on github been answered. pl let us know if that helps