Change Port Allocations?

Portainer was previously running (some weeks back), no issues and I often leave this time period in-between checking / using Portainer and my containers.

Now when requesting http://server:9000 it just says “Loading Portainer” with some animation. Nothing happens.

So I stopped & removed the container, pulled the latest (1.24.1) image and redeployed with syntax (taken from the Portainer installation web page and having created a Docker volume):

sudo docker run -d -p 9000:9000 --name=portainer -v portainer_data:/data -v /var/run/docker.sock:/var/run/docker.sock portainer/portainer

This still didn’t work. So I added the extra 8000 port, which I haven’t had to do previously:

sudo docker run -d -p 9000:9000 -p 8000:8000 --name=portainer -v portainer_data:/data -v /var/run/docker.sock:/var/run/docker.sock portainer/portainer

But I have another web server running on this port number. So I tried adjusting this:

sudo docker run -d -p 9000:9000 -p 8001:8000 --name=portainer -v portainer_data:/data -v /var/run/docker.sock:/var/run/docker.sock portainer/portainer

Same result. Viewing the log files:

$ sudo docker logs -f portainer
2020/08/19 11:54:21 Warning: the --template-file flag is deprecated and will likely be removed in a future version of Portainer.
2020/08/19 11:54:22 Templates already registered inside the database. Skipping template import.
2020/08/19 11:54:22 server: Reverse tunnelling enabled
2020/08/19 11:54:22 server: Fingerprint 15:1c:62:50:96:2e:d2:c3:e6:4b:40:59:f8:4f:80:a4
2020/08/19 11:54:22 server: Listening on 0.0.0.0:8000...
2020/08/19 11:54:22 Starting Portainer 1.24.1 on :9000
2020/08/19 11:54:22 [DEBUG] [chisel, monitoring] [check_interval_seconds: 10.000000] [message: starting tunnel management process]

If I check the listening port (8001):

$ netstat -ano | grep 8001
tcp6       0      0 :::8001                 :::*                    LISTEN      off (0.00/0/0)

Its listening on IPv6!!!

And now we are caught up with the history… Can anyone assist please?

Some extra content - I saw on the installation page / guide, you can omit the 8000 port exposure. However, if I omit that part of the initial container deploy command, there is no change in behaviour:

sudo docker run -d -p 9000:9000 --name=portainer -v /docker/containers/portainer/config:/data -v /var/run/docker.sock:/var/run/docker.sock portainer/portainer

Note, I have also used a different volume for persistent data - this was my original location and I saw a log entry about upgrading the database version the first time I ran it with this configuration.

Hmm I often times see Portainer stuck on a loading screen when something plays up in cache.

I recommend:

  • Clearing cache
  • Trying an incognito window
  • Trying a different browser