Feature proposal: Env. file parsing, composer update

I was using stacks, when I got bunch errors because portainer supports docker composer version 2 only, would it be posible to update docker-compose version ?

Second thing: It would be nice, if we could parse file with enviroment variables and fill enviroment variables files.

Thanks

Hi there,
Our recommended approach is to run docker as a swarm, you will then have access to compose version > 2 & its related features. Portainer doesn’t support compose version > 2 in a standalone environment as the library we use to do this, Libcompose is unmaintained.

You can follow the continued discussion on the topic on our github here