Fix MAC address to allow router port forwarding

Container of portainer is systematically changing MAC address after reboot the Host.
This is the case also with container running on host network.

Overall this prevent any possibility of port forwarding on from WAN to LAN based on MAC address.

How can I address that as I need to connect to some docker application from remote?

hi
if u are starting portainer frm docker run, pl try --mac-address option. this preserves mac address for the container. or use macvlan/ipvlan network driver

Hi,
To my (poor) understanding, the layer that is exposed to LAN is at host level.
Running portainer at host level will disable MAC option or any network values override (other than name), which makes sense. Indeed, I would expect this to be controlled at io docker level not container level.

If I’m correct, at bridge level, MAC option for a container will not be exposed to LAN router but, bridge being a subnetwork as such, this is exposed to host network only not further down to router LAN layer… Back to square one.

My intuition was that there is a portainer.io option that needs to be changed but I couldn’t find any documentation about this.