Portainer on Alpine Linux

I’ve made a clean installation of alpine linux 3.10.2, and installed docker 19.03.2 using the instructions provided on the alpine wiki ( https://wiki.alpinelinux.org/wiki/Docker ). I’ve installed Portainer 1.22.0 using:

docker volume create portainer_data docker run -d -p 9000:9000 -p 8000:8000 --name portainer --restart always -v /var/run/docker.sock:/var/run/docker.sock -v portainer_data:/data portainer/portainer

and I can create an admin account and configure Portainer to monitor the local docker installation using a web browser on port 9000

However, my local endpoint is shown as offline, and I can see a steady flow of Portainer log messages (if I run without the -d option):

2019/10/09 12:28:54 background schedule error (endpoint snapshot). Unable to create snapshot (endpoint=local, URL=unix:///var/run/docker.sock) (err=Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Get http://%2Fvar%2Frun%2Fdocker.sock/_ping: dial unix /var/run/docker.sock: connect: permission denied)

my local docker socket appears to be present and correct in /var/run:
srw-rw---- 1 root docker 0 Oct 9 10:33 docker.sock

I’ve tried installing the same versions of docker and Portainer on Ubuntu 18.04 and I can see the containers within the local endpoint correctly, though the permissions / ownership of /var/run/docker.sock appear to be identical.

What am I doing wrong when I try to use Portainer on Alpine linux?